1. 您现在的位置:首页
  2. 下载中心
  3. 旗下软件
  4. 挂机锁
  5. Source挂机锁5.0 解锁模版

Source挂机锁5.0  解锁模版

Source挂机锁5.0 解锁模版

  • 软件大小:0 kb
  • 软件版本:1.0
  • 开发作者:Source   访问官网
下载附件

自定义解锁模版


【函数说明】

程序主要调用解锁模版中的三个函数,也即是您所制作的解锁Dll文件中必须要能被调用的三个函数


  1. Verification

    返回类型   文本型

    主要用途   返回该解锁DLL的名称

    返回格式   000000,xxxxx (xxxx为您的解锁模式名称,前面6个0需要保持原样,中间通过逗号分隔)


  2. BuildPassword

    返回类型   逻辑型

    主要用途   返回密码是否设置成功

    返回格式   

    详细说明   当主程序选择您的解锁模式时,点击启动后,通过调用这个函数进行设置密码,并通过该函数返回的真与假判断是否已设置成功,如果设置成功则进入锁定界面,如果未成功则不进入


  3. VerificationPassword

    返回类型   逻辑型

    主要用途   返回密码是否正确

    返回格式   

    详细说明   当主程序在锁定模式下,用户点击解锁后,主程序自动调用该函数,并根据该函数返回的真与假判断是否解除锁定状态


【其他说明】

LockData.dat 为保存用户解锁数据的主文件,也即是用户通过主程序调用解锁模块后,当用户设置完成密码以后,解锁模块生成的解锁数                          据文件必须为该文件

Config.ini       为程序主配置文件,如果用户解锁数据为加密的,则密钥信息需要放在该文件中的LockData项中的Key子项


【如何加载】

在主程序目录下,找到Config.ini文件并打开,打开后找到[system]项,在[system]项下的dlls=后面加上您的解锁模块名称,多个模块通过英文的逗号进行分割,例如:dlls=PasswordLock.dll,SudokuLock.dll,RandomLock.dll


【易语言模版】

.版本 2


.子程序 Verification, 文本型, 公开, 程序校验


.子程序 BuildPassword, 逻辑型, 公开, 密码生成


.子程序 VerificationPassword, 逻辑型, 公开, 密码校验



在线客服
  • 技术支持 点击这里给我发消息